Allgemein Problem bei Portierung und Upgrade

A

achai

GAST
Hallo zusammen,
Infos:
Alter Server:
Win2003, IIS6.0, PHP 5.1.6, MySQL 5.0.24, Mediawiki 1.6.6 (latin1)
Neuer Server:
Win2008R2 x64, IIS6.1, PHP 5.3.6, MySQL 5.0.24, Mediawiki 1.16.4 (utf8)

ich versuche gerade mein Mediawiki 1.6.6 (latin1)vom Win2003 (IIS5, PHP 5.1) auf Windows2008R2x64 (IIS7, PHP5.6) zu portieren.
Latin1
Utf8
Leider kann ich schon gar nicht mehr die Seite aufrufen, wenn das Wiki einfach kopiere. Es erscheint noch nicht mal eine Fehlermeldung.

Wenn ich auf dem neuen Server die neue MediaWiki-Version 1.16.3 (utf8) installiere und mich mit der MySQL-Datenbank (5.0.24) verbinden, klappt erstmal alles: bis auf die Artikelnamen mit Sonderzeichen und Dateinamen mit Sonderzeichen, die vorher normal mit äöü etc. erschienen, sind nun „Ãœ“ oder ähnlich.

Schalte ich in der Localsettings.php $wgDBmysql5 = true;, dann stimmt alles,.. aber ich über die Spezialseiten nicht mehr auf die Dateiliste zugreifen:
Fehlermeldung vom IIS:
„Serverfehler
500 - Interner Serverfehler.
Problem bei der gesuchten Ressource. Sie kann nicht angezeigt werden.“

Bin ich aber schon in der Dateiliste und schalte $wgDBmysql5 = false; dann kann ich in der Dateiliste navigieren, allerdings sind dann einige Dateien mit äöü etc. nicht aufrufbar oder vorhanden, bzw. kommt die Meldung wie oben geschrieben.

Hat jemand evtl. eine Idee?


Viele Grüße

Achai
 

Holger Schrag

Seitenbetreiber
Teammitglied
Administrator
Netzwerk BE Geislingen
16. Februar 2005
2.409
227
83
46
Geislingen an der Steige
www.hollosch.de
AW: Problem bei Portierung und Upgrade

Wie groß ist denn Deine Datenbank ?
Ich hatte dieses Umlaut-Problem auch schon einmal und habe das dann "händisch" in der Datenbank mit "Suche+Ersetzen" gemacht...

Bei Datenbanken bis 30 MB wäre das glaub schon machbar... Ich hänge Dir mal meine "übersetzung" an.

Wenn das keine Option ist, einfach nochmal melden...
 
A

achai

GAST
AW: Problem bei Portierung und Upgrade

Hallo hollosch,

Vielen Dank schonmal für Deine Antwort.
Wenn ich [FONT=&quot]$wgDBmysql5 = true; setze werden die namen mit Umlauten korrekt angezeigt, aber sind nicht aufrufbar (500er-Meldung. Wenn ich [/FONT][FONT=&quot]$wgDBmysql5 = false lasse, dann werden nicht die Umlaute in der Wörtern angezeigt, sondern die Ersatzzeichen,... allerdings sind dann die Dateien und Seiten aufrufbar.

Und weiter habe ich generell mit Mediawiki (auch bei Neuinstallationen) Probleme auf der neuen Serverumgebung. Z.B. werden bei Neuinstallationen, nachdem das Setup ausgeführt und die localsettings.php in die root kopiert wurde, die meldung :

[/FONT] [FONT=&quot]500 - Interner Serverfehler.[/FONT]
[FONT=&quot]Problem bei der gesuchten Ressource. Sie kann nicht angezeigt werden.[/FONT]


ausgespuckt.

Die Umgebung ist wie folgt:
Win2008R2 x64, IIS6.1, PHP 5.3.6, MySQL 5.0.24, Mediawiki 1.16.4 (binary)



Kann es sich dabei nicht um ein anderes Problem handeln, welches miteinander zusammenhängt?

Viele Grüße

Achai
 
A

achai

GAST
AW: Problem bei Portierung und Upgrade

Hallo,

ich habe jetzt folgendes durchgeführt:

· sql-Datei von MySQLDumper herunterladen.
· Anschliessend Zeichen wie folgt mit „WinVi“ ersetzen:
ü = ü
ö = ö
ß = ß
ä = ä
Ãœ = Ü
Ö = Ö
Ä = Ä
– = &
„ = "
“ = "
· Nun ein neues Wiki installieren (unten: Database character set = binary)
· Nun die Datei in die WikiDatebank (Datei-Zeichensatz:Utf8) über MySql-Administrator einfügen


Das Ergebnis war, dass alle Umlaute komplett durch Sonderzeichen ersetzt wurden.

Hätte ich evtl. anders vorgehen sollen?


Grüße

Achai
 

Holger Schrag

Seitenbetreiber
Teammitglied
Administrator
Netzwerk BE Geislingen
16. Februar 2005
2.409
227
83
46
Geislingen an der Steige
www.hollosch.de
AW: Problem bei Portierung und Upgrade

Du musst die Zeichen in der Datenbank ersetzen, nicht wieder neu importieren.

1. DB exportieren mit "Drop tables" und "if not exists"
2. sql-Datei mit einem Texteditor öffnen (z.B. PSPad)
3. Zeichen sichen und ersetzen
4. Inhalte der DB z.B. vie PHPmyAdmin direkt einspielen.

Das hat bei mir funktioniert
 
A

achai

GAST
AW: Problem bei Portierung und Upgrade

Guten Morgen Hollosch,

vielen Dank für Deine Antwort.

Habe inzwischen festgestellt, dass die zu importierende Datenbank auf das Wiki 1.6.6 (läuft auf MySQL 5.0.24 -> installiert zuerst auf MySQL 4) Datenbank aufsetzt.
Die aktuelle Wikiversion auf dem neuen Server ist aber 1.16.5.

Habe versucht im Wiki 1.16.5 über "\maintenance\update.php --upgrade" die Datenbankstruktur upzugraden,... klappt aber leider nicht:
- im Browser erscheinen jetzt: [FONT=&quot]�[/FONT] und ? Zeichen
- wenn $wgDBmysql5 = true -> Fehler wird im Browser angzeigt
- im Browser Zeichenkodierung ändern, dann wird im Browser: z.B.: "�" angezeigt



Vielleicht weisst Du, wie ich jetzt die alte Wiki-Version 1.6.6 auf die aktuelle 1.16.4 upgrade?

Sitze jetzt schon fast zwei Wochen an dem Problem.

Viele Grüße

achai
 

wartburgritter

Neues Mitglied
Registrierter Benutzer
25. Juni 2011
1
0
1
45
AW: Problem bei Portierung und Upgrade

Hallo zusammen,

bin auf den weiten den internets irgedwie auf das forum gestossen. Da ist mir das thema ins auge gefallen. Ich habe ein mediawiki V1.6.10 installiert. Nur für mich, wo ich alles mögliche reinschreibe. Ist ganz praktisch, keine zettelwirtschaft mehr daheim, und alle informationen immer abrufbar, auch wenn ich sie unterwegs brauche. Sehr hilfreich vor allem bei computeradministration in der verwandschaft oder bei kollegen.

Nun steht irgendwann ein upgrade an und ich hab mir schon gedacht dass wird schwierig bei so einer alten version.

Wie sieht es aus, hast du eine brauchbare lösung gefunden.

Was ist mit folgender seite:

http://www.mediawiki.org/wiki/Manual:Upgrading/de

Hast du das mal getestet?

Gruss der wartburgritter
 
G

Gelöschtes Mitglied 117

GAST
AW: Problem bei Portierung und Upgrade

Probier's einfach! (Erst Backup von Dateien und SQL, notfalls alles wieder zurückspielen und weiter gucken).

Besten Gruss
Bruno